1185

Prepping the move of the current web server for all my domains to the new box. unfortunately, apache virtual hosts are not playing nice. All the named Virtual Hosts are responding with the root host’s documentroot, like it’s not getting the name in the request.

I’ve had to fix this once before, but damn if I can remember how I did it.

Grrr.

About Kevin Sonney

Kevin Sonney - who, contrary to popular opinion was NOT raised by wolves - grew up in central North Carolina. He fell into the technology field by accident in 1991, when he gave up the wild and crazy lifestyle of an on-air AM radio DJ to become a mundane technical support monkey. The technology industry has never really recovered from this. Kevin has worked for such names as IBM, Red Hat, webslingerZ, and Lulu Technologies (we won't mention the ones that didn't survive the experience). He currently works as a Linux Administrator for Apptio. In his spare time he rescues stray animals and plays video games with his two sons. His wife, we're sad to say, helps him get past the really hard bits. Kevin is still not very mundane, he just got better at hiding it.
This entry was posted in Uncategorized. Bookmark the permalink.

3 Responses to 1185

  1. detritus says:

    What new box are you using?

  2. alchemist says:

    Well, not new, so much as new(er). midgard.darkcanvas.com (the current box) is a PPro 200 w/Red Hat Linux 6.2. moltress (the new one) is a P2/350 with Red Hat Linux 7.3 on it.

    Moltress is currently 99% inaccessable from the public net. It’s the internal NFS, NIS, and Samba server, and the jabber.darkcanvas.com server. Once I get web & DNS moved over to it, I can do sendmail & imapd switchovers late one night, and retire midgard…or just re-task it for something else….

  3. flavor says:

    you already have it fixed by now, but yeah, links isn’t sending the nice HTTP/1.1 Host: header, so apache doesn’t know to map the request to one of the vhosts :)

Comments are closed.